Vous n'êtes pas connecté.
Forum : Besoin d'aide sur PC ? Page : 1, 2, 3, 4 >>
Auteur Message
Shiru
image du rang
Garde Shinra


Posté le 13 juin 2011 à 05:07 | Sujet : Coupures de son par les cinématiques
Bonjour à tous.

Je viens (enfin) de finaliser, régler, tester mon installation d'FF7 sur PC (windows seven 32bits qui tourne en machine virtuelle sur un Apple MBP, Mac OS X.6).
Tout fonctionne niquel (si si !).
Après des soucis "habituels" d'installation qui se lance pas, après un enfer pour faire marcher les cinématiques (écran noir...) et un petit combat supplémentaire pour les patchs (chocobo, "ff7 sur vista", openGL, fenetres transparentes et correction de la défense magique) eh bien.... tout fonctionne !

Enfin, tout... je serais pas ici si tout fonctionnait niquel
J'ai un problème que je pense mineur. Je m'en suis aperçu en démarrant, le coeur battant, ma nouvelle "première partie".

Il s'avère que de temps en temps, je n'ai pas de sons pendant les cinématiques et/ou pas de bruitages pendant certaines cut scenes. Je m'explique.
Attaque du premier réacteur mako. Cinématique d'intro, ok. Jouabilité, ok. Son, musique, bruitages en combat, hors combat, ok. Jusqu'au moment où après la fuite le réacteur pète, là PAF, pas de son, pas de bruit d'explosion genre "PAOUUUUFFFFFRR" (j'le fais bien hein ? :P).
Ensuite, aucun bruitage lorsque Jesse pianote pour faire exploser la porte. Pas non plus de bruitage de l'explosion de la porte.
J'ai bien la musique après sur les quais, j'ai bien le son du train quand il passe, et arrivé dans le train, quand Barret tape sur la caisse, pas le moindre bruit. Pas de "BIM" sonore de son bras musclé. Quand Cloud entre dans le wagon, pas de bruit non plus. Il s'est changé en ninja.

Alors, une idée d'où tout ça pourrait venir ? J'espère que c'est pas simplement la version PC qui a choisi d'éliminer ces sons là, parce que je porte plainte sinon xD Miciiii :D

[Ce message a été édité par son auteur pour la dernière fois le 13 juin 2011 à 21:53]
23 messages
Voir le profilLien du message Aller en haut de page
Acro
image du rang
Administrateur


Posté le 13 juin 2011 à 05:10 | Sujet : Coupures de son par les cinématiques
C'est joli.

Pour le son, problème que j'ai déjà entendu mais je ne sais pas d'où ça vient.
FF7Music installé ?

  Patch de retraduction de Final Fantasy VII, Néo-Midgar (inclus dans le pack SYW)

57095 messages
Voir le profilLien du message Aller en haut de page
Shiru
image du rang
Garde Shinra


Posté le 13 juin 2011 à 05:13 | Sujet : Coupures de son par les cinématiques
Euh.. Non. Je peux essayer si tu penses que ça peut corriger le problème.
23 messages
Voir le profilLien du message Aller en haut de page
Acro
image du rang
Administrateur


Posté le 13 juin 2011 à 05:16 | Sujet : Coupures de son par les cinématiques
Aucune idée. Je ne sais pas pourquoi, je ne l'ai jamais eu.
Erreur du guide, je voulais certainement dire la salle 10, non ?

  Patch de retraduction de Final Fantasy VII, Néo-Midgar (inclus dans le pack SYW)

57095 messages
Voir le profilLien du message Aller en haut de page
Shiru
image du rang
Garde Shinra


Posté le 13 juin 2011 à 05:18 | Sujet : Coupures de son par les cinématiques
Oh, oui, possible. La phrase deviendrait alors :

"Les salles 1 et 10 ne sont pas signalées par des flèches rouges sur la version PC, et la salle 10 sera accessible en contournant la 8."

Enfin c'est du détail, tout le monde avait saisi hein ^^ Rien d'important. J'vais essayer avec FF7Music.

*** EDIT : Le problème de debug room auquel ces réponses de "salles" font référence a été déplacé dans un nouveau sujet dans cette même partie du forum ***

[Ce message a été édité par son auteur pour la dernière fois le 13 juin 2011 à 21:51]
23 messages
Voir le profilLien du message Aller en haut de page
Acro
image du rang
Administrateur


Posté le 13 juin 2011 à 05:19 | Sujet : Coupures de son par les cinématiques
C'est toujours important une erreur. ^^
(d'ailleurs le Debug Room en est plein tant que ma maj n'est pas là )
Sinon pour les bruitages, essaie aussi de voir si tu as l'Open GL.

  Patch de retraduction de Final Fantasy VII, Néo-Midgar (inclus dans le pack SYW)

57095 messages
Voir le profilLien du message Aller en haut de page
Shiru
image du rang
Garde Shinra


Posté le 13 juin 2011 à 05:22 | Sujet : Coupures de son par les cinématiques
Ca oui je l'ai installé, vu que je joue en fenestré (quand même plus pratique, et le léger lissage est pas négligeable). Donc je pense qu'à ce niveau je suis à jour.
23 messages
Voir le profilLien du message Aller en haut de page
Acro
image du rang
Administrateur


Posté le 13 juin 2011 à 05:25 | Sujet : Coupures de son par les cinématiques
Et t'es sûr par exemple de ne pas avoir appuyé à l'extérieur de la fenêtre pendant la cinématique (j'ai du mal à y croire vu que c'est arrivé à d'autres gens avant) ? Car en mode fenêtré, le son ne reste que si tu es réellement sur le jeu.

  Patch de retraduction de Final Fantasy VII, Néo-Midgar (inclus dans le pack SYW)

57095 messages
Voir le profilLien du message Aller en haut de page
Shiru
image du rang
Garde Shinra


Posté le 13 juin 2011 à 05:27 | Sujet : Coupures de son par les cinématiques
Le problème ne se pose pas trop sachant que pendant que j'avais des bruitages manquants (les coups de poings de Barret sur la caisse par exemple) j'avais bien la musique d'ambiance du wagon.
Du moins il me semble, tu me mets le doute, je vais re-vérifier xD
23 messages
Voir le profilLien du message Aller en haut de page
KartSeven
image du rang
Gast


Posté le 13 juin 2011 à 14:13 | Sujet : Coupures de son par les cinématiques
C'est tout à fait possible si tu n'étais pas réellement dans le jeu. Donc oui, revérifie. ^^
13572 messages
Voir le profilLien du message Aller en haut de page
Shiru
image du rang
Garde Shinra


Posté le 13 juin 2011 à 17:13 | Sujet : Coupures de son par les cinématiques
Bon.
J'ai remis dans mon "ff7_opengl.cfg", en ligne 18, "fullscreen = true" afin de ne plus être perturbé par une éventuelle mauvaise manip du mode fenêstré. Avec le son de mon ordi à fond, je confirme une chose :
Au moment de s'échapper du réacteur mako nord, à l'écran où la cinématique de l'explosion se déclenche, on a toujours la musique 'bombing mission', les persos courent sur la passerelle, Cloud aide Jessie à se décoincer, la cinématique débute, on entend la première demi-seconde du son de cette scène cinématique, puis le son se coupe. O_O.
Ensuite, toujours pas de bruit pendant que Jesse pianote pour faire sauter la porte, pas de bruit pendant la cinématique de la petite explosion... La musique revient à l'écran où Cloud rencontre Aeris. Mais de l'explosion du réacteur à ce moment, silence complet.

J'ai regardé dans mes cinématiques, la cinématique de l'explosion du réacteur s'ouvre bien avec VLC, et contient bien le son de l'explosion.
Celle de l'explosion de la petite porte, en revanche ("mk8") ne contient aucun son, j'en déduis que cette fois c'est un bruitage du jeu qui ne se lance pas, idem pour le pianotage de Jesse ou le coup de poing de Barret dans le train, ou l'arrivée de Cloud par la porte du wagon... Bref je suis à deux doigts de réinstaller le jeu entier sans les patches, pour voir si ça vient pas d'une erreur de ma part...

[Ce message a été édité par son auteur pour la dernière fois le 13 juin 2011 à 17:13]
23 messages
Voir le profilLien du message Aller en haut de page
Acro
image du rang
Administrateur


Posté le 13 juin 2011 à 17:15 | Sujet : Coupures de son par les cinématiques
Comme t'es pas le premier à qui ça arrive, ça ne doit pas être une mauvaise manip, mais plutôt un bug récurrent :/

  Patch de retraduction de Final Fantasy VII, Néo-Midgar (inclus dans le pack SYW)

57095 messages
Voir le profilLien du message Aller en haut de page
Shiru
image du rang
Garde Shinra


Posté le 13 juin 2011 à 21:24 | Sujet : Coupures de son par les cinématiques
J'ai des précisions. J'aurais bien voulu prendre une vidéo du phénomène pour que ça soit plus clair, mais je connais pas d'outil de capture vidéo gratuit que je pourrais utiliser pour vous montrer ces problèmes de son sur mon jeu.

J'ai constaté une chose, qui me fait maintenant soupçonner les scènes cinématiques de foutre le dawa dans l'histoire.

Contrairement aux divers autres cas "récurrents" rencontrés sur ce forum ou sur celui de JV.COM, moi j'ai tous les bruitages, tous les sons et toutes les musiques, la plupart du temps, et notamment en combat où aucun problème n'est à signaler.

Ce qui se passe en réalité et je viens de m'en apercevoir, c'est une réelle coupure TOTALE du son du jeu APRÈS ou PENDANT une scène cinématique, et ce jusqu'au lancement de la prochaine musique d'ambiance. Explications :

** Réacteur Mako Nord.
Tous les sons, OK.
Lors de l'explosion finale, dès le départ de la cinématique, TOUT SON se coupe, l'explosion est totalement silencieuse. Mais en réalité, c'est TOUT le son du jeu qui se coupe, jusqu'au lancement par le script de la prochaine musique d'ambiance, celle qui commence à l'écran où l'on rencontre Aeris. Jusque là, ni les bruitages (pianotage de Jesse, explosion de la porte) ni les petits bruits du curseur dans les menus ne sont audibles !
AUCUN son ne sort du jeu, comme si la scène cinématique les avait tous fait planter.

** Ecran de rencontre d'Aeris.
La musique "Anxious heart" se lance, et là tous les bruitages redeviennent audibles, dans les menus, dans les choix de dialogues avec Aeris.

** Ecran de l'attaque des gardes Shinra sur le quai.
Musique toujours ok, bruitages ok (déplacement du curseur dans les menus, mitraillettes des gardes).
Cinématique où Cloud saute sur le train, SON OK.
Mais dès qu'elle se termine, plus aucun son.

** Ecran dans la soute du train.
Aucun son d'ambiance (normalement, son d'ambiance "bruit du train" sans musique (vérif sur PS1)), aucun bruitage (bruit de cloud sur le toit, bruit de Barret qui tape sur la caisse, bruit de la porte qui s'ouvre, pas même le bruit du curseur dans le menu lorsqu'il se retrouve tout seul !). Mais dès le saut de Cloud dans le wagon d'à côté...

** Ecran du premier wagon.
Musique + bruitage OK. Anxious Heart se re-lance, les bruitages sont re-audibles, le bruit du train, le bruit des portes, du moniteur, le bip du haut parleur, le bruit du curseur dans les menus, tout ok.)

Du coup, je crois que c'est tout simplement mes scènes cinématiques qui font bugger mon son, et que celui-ci se réinitialise soit lors d'un changement d'écran, soit lors du chargement de la musique d'ambiance suivante (je dirais plutôt "jusqu'à un changement d'écran". Ca me parait plus crédible d'un point de vue programmation). Reste à savoir pourquoi. Des hypothèses ?

PS : Merci de votre aide

[Ce message a été édité par son auteur pour la dernière fois le 13 juin 2011 à 21:33]
23 messages
Voir le profilLien du message Aller en haut de page
Œil de Nuit
image du rang
Rude


Posté le 13 juin 2011 à 21:36 | Sujet : Coupures de son par les cinématiques
Pas une solution mais un indice : ça me le fait aussi sans système virtualisé, et que ce soit en fenêtré ou plein-écran. Donc ça élimine ça. Je pensais que si je ne l'avais plus eu depuis un moment, c'était depuis que j'avais mis l'OpenGL, mais apparemment, coïncidence.

Pas non plus une solution mais une hypothèse : je n'ai toujours pas pris la peine de vérifier : le temps d'accès au disque dur. Dans les paramètres de gestion d'alimentation, j'ai passé de 1 à 10 minutes le chrono de veille de disque dur.

Je pense à ça car les arrêts de sons étaient toujours apparus (chez moi) suite à un changement de musique ou à un bruitage (donc fréquemment après une vidéo). Aussi, c'était toujours dans les mêmes endroits.

Probablement inutile de le dire mais pense évidemment à le faire sur ton système hôte et ton système virtualisé. ^^

Fallait pas hésiter à créer deux sujets. Je te conseille de couper le passage sur la debug room et de le coller dans un nouveau sujet.

[Ce message a été édité par son auteur pour la dernière fois le 13 juin 2011 à 21:39]
6309 messages
Voir le profilLien du message Aller en haut de page
Shiru
image du rang
Garde Shinra


Posté le 13 juin 2011 à 21:54 | Sujet : Coupures de son par les cinématiques
Je vais creuser de ce côté, merci Œil de Nuit
Me reste juste à trouver comment faire ce réglage sur Mac (système hôte).
J'ai aussi scindé en deux le sujet, et renommé celui-ci plus en rapport avec le réel problème.
23 messages
Voir le profilLien du message Aller en haut de page
scargi
image du rang
Garde Shinra


Posté le 03 septembre 2011 à 05:37 | Sujet : Coupures de son par les cinématiques
Bonjour, je up un peu le sujet

Je rencontre le même soucis (au même moment)

J'ai réinstallé FF7 sous Seven, j'ai testé avec et sans mods et le problème persiste. j'ai tenté d'installé FF7music mais celui ci n'accepte pas de lancer le jeu....

Si une personne aurait connaissance de ce problème, ca serait sympa de donner un coup de main

Edit :

Lorsque je modifie la ligne MIDI_DeviceID (1) au lieu de (0) dans la base de registre, je n'ai plus de musique mais lors de la vidéo le son est présent.

Edit 2 :

Soucis réglé, j'ai installé FF7Music + openGL et j'ai désactivé les sons dans la base de registre comme suit :

Dans MIDI :
MIDI_DeviceID : (1)
Options : (0)

et

Dans SOUND:
Options : (0)

J'ai suivi le tuto pour les ziks de FF7Music (Modifier le fichier opelGL, etc puis je lance le jeu via FF7Music et tout est ok,

les sons des vidéos sont présents, idem pour les bruitages.

Si jamais ca peut aider quelqu'un

[Ce message a été édité par son auteur pour la dernière fois le 03 septembre 2011 à 06:55]
2 messages
Voir le profilLien du message Aller en haut de page
Acro
image du rang
Administrateur


Posté le 03 septembre 2011 à 16:05 | Sujet : Coupures de son par les cinématiques
Je rajouterai la résolution du problème à la nouvelle page de tutorial de la version PC, merci.

  Patch de retraduction de Final Fantasy VII, Néo-Midgar (inclus dans le pack SYW)

57095 messages
Voir le profilLien du message Aller en haut de page
AlexRNL
image du rang
Garde Shinra


Posté le 18 septembre 2011 à 18:25 | Objet du message : Merci
Je rencontre ce problème également, je teste ça ce soir

Merci de partager ta solution en tout cas, certaines cinématiques sont bizarres sans le son ^^
9 messages
Voir le profilLien du message Aller en haut de page
Acro
image du rang
Administrateur


Posté le 18 septembre 2011 à 18:34 | Sujet : Coupures de son par les cinématiques
Réinstalle le jeu, sinon.

  Patch de retraduction de Final Fantasy VII, Néo-Midgar (inclus dans le pack SYW)

57095 messages
Voir le profilLien du message Aller en haut de page
SBahamut
image du rang
Garde Shinra


Posté le 04 mars 2012 à 17:27 | Sujet : Coupures de son par les cinématiques
Excusez-moi de remonter ce vieux sujet mais je rencontre le même problème.

Est-ce qu'il serait possible d'avoir la solution énoncé par Scargi en un petit peu mieux détaillé car j'avoue ne pas avoir tout compris au manipulation qu'il a fait^^"
17 messages
Voir le profilLien du message Aller en haut de page
Page : 1, 2, 3, 4 >>
Qui est en ligne ?
Aucun utilisateur en ligne dans les 5 dernières minutes.
Jeux entre forumeurs
Le Tarot des Anciens



Inscrits : yuyu, Threemansking
Interrupted by Hanabi



Inscrits : Acro
SpeciNames



Le Démineur de MSN



Inscrits : Acro